設為首頁加入收藏

微信關注
官方微信號:qingfeng7777777a
加關注獲取每日精選資訊
股票入門歡迎您加入
廣告服務聯系我們網站地圖

三個成交量選股公式

2019-05-18 22:50:45 技術分析知識庫

使用說明:

這里發的指標均是通達信電腦版軟件,手機軟件有的可能不通用。

分別寫三個公式:以MAVOL 5; MAVOL 35; MAVOL 135;為三根量線。

1:條件——個股30個以上交易日量柱均小于MAVOL 135線,某一日個股成交量異動,量柱穿越MAVOL135線時預警選股(如下圖1)

MV5:=EMA(V,5);{5日均量線是主力啟動線}

MV35:=EMA(V,35);{35日均量線是主力洗盤線}

MV135:=EMA(V,135);{135日均量線是資金異動線}

REF(EVERY(V<MV135,30),1) AND CROSS(V,MV135);

2:條件——個股20個以上交易日均滿足 MAVOL 135>MAVOL 35 >MAVOL 5量 線,某一日個股MAVOL 5 量 線 上穿(即金叉)MAVOL 35量線時預警選股(如下圖2)

 MV5:=EMA(V,5);{5日均量線是主力啟動線}

MV35:=EMA(V,35);{35日均量線是主力洗盤線}

MV135:=EMA(V,135);{135日均量線是資金異動線}

REF(EVERY(MV135>MV35 AND MV35>V,20),1) AND CROSS(V,MV35);

 

3: 條件——當60日均線與120均線多頭排列時, 個股 滿足 MAVOL 35> MAVOL 135 > MAVOL 5 量 線,且量柱收陰線時預警選股(如下圖3)

 

MV5:=EMA(V,5);{5日均量線是主力啟動線}

MV35:=EMA(V,35);{35日均量線是主力洗盤線}

MV135:=EMA(V,135);{135日均量線是資金異動線}

EVERY(MA(C,60)>MA(C,120),60) AND EVERY(MV35>MV135 AND MV135>MV5,60);


 

指標源碼:

 

AX:=PERIOD;

BL:=IF(AX=0,150,IF(AX=1,50,IF(AX=2,30,IF(AX=3,17,IF(AX=4,15,IF(AX=5,8,

IF(AX=6,3,IF(AX=7,2,IF(AX=8,50,IF(AX=9,3,1.3))))))))));

FM:=(EMA(CLOSE,1.414*9+1));

FCL:=IF(FM<=0.05,ABS(FM)+0.1,0);

DIF:=(EMA(CLOSE,9)-EMA(CLOSE,2*9+2))/(FCL+FM)*60*BL*4+260,COLORLIRED,LINETHICK1;

DEA:=EMA(DIF,9*0.75),COLORGREEN,LINETHICK1;

MACD:=2*(DIF-DEA)+200;

STICKLINE(MACD>200 AND MACD<REF(MACD,1),200,MACD,1,0),COLORGREEN;

STICKLINE(MACD>200 AND MACD>REF(MACD,1),200,MACD,1,0),COLORMAGENTA;

STICKLINE(MACD<200 AND MACD<REF(MACD,1),200,MACD,1,1),COLORLIGREEN;

STICKLINE(MACD<200 AND MACD>REF(MACD,1),200,MACD,1,1),COLORFF00FF;

DRAWBAND(DIF,RGB(200,50,55),DEA,RGB(100,400,100));

DRAWTEXT(CROSS(DIF,DEA),DIF*0.93,'B'),COLORYELLOW;

L1:=(CLOSE-LLV(LOW,11))/(HHV(HIGH,11)-LLV(LOW,11))*100*4+10;

K:SMA(L1,3,1),COLORGRAY;

D:SMA(K,3,1),COLOR38B0DE;

W:IF(K>REF(K,1),K,DRAWNULL),COLORMAGENTA,LINETHICK2;

MAXV:=CONST(HHV(VOL,100));

MAXD:=CONST(MAX(ABS(HHV(DIF,100)),ABS(LLV(DIF,100))));

BS:=MAXV/MAXD*1.5;

CC:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN*0.8/BS,DRAWNULL);

STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,CC,0,-1,-1),COLOR00C0C0;

AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

買盤:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+

(CLOSE-LOW)),VOL/2)),NODRAW;

買:買盤/10000,COLORRED,NODRAW;

賣盤:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,

0-AA*(HIGH-LOW),0-VOL/2)),NODRAW;

賣:賣盤/10000,COLORGREEN,NODRAW;

差額:(買盤+賣盤)/10000,COLORWHITE,NODRAW;

{BB:=(買盤+賣盤);}

三日凈流入:SUM (差額,3),COLORMAGENTA,NODRAW;

STICKLINE(買盤>0 OR 賣盤<0 ,0,VOL/BS,2,0),COLORLICYAN;

STICKLINE(買盤>0,0,買盤/BS,2,0),COLORRED;

[!--temp.sitename--]聲明:資訊來源于互聯網,屬作者個人觀點,僅供投資者參考,并不構成投資建議。投資者據此操作,風險自擔。

46二肖中特